Pode na 1.7.10?

Posso jogar na 1.7.10?

Sim, qualquer versão a partir da 1.7.2 para+.